1st Time Developer - Assistance Required!

Status
Not open for further replies.

1K73

Member
Joined
29 Oct 2005
Messages
132
Hi guys,

Having developed for MSTS for a number of years, I thought it time to dabble in BVE...but not all is good!

Using the 37901 files as a basis (Sorry Martin! The loco won't be released...even if it advances) I've had a shot at a 25/2 but the following problem is in place :(

http://img88.imageshack.us/img88/5696/helppk5.jpg

The blue is obviously supposed to be transparent with a nice view of the track in front of me - but this is not the case. The blue used matches that on 37901 and also that mentioned in the panel2.cfg file - and the images used are made to the same resolutions as the original 37901 shots.

Is there something blatently obvious i'm missing here?

Dave
 
Sponsor Post - registered members do not see these adverts; click here to register, or click here to log in
R

RailUK Forums

guillyman

Member
Joined
12 Sep 2007
Messages
148
Location
South London
Hi, Dave!
Now I may be wrong, since I've never actually built a train before, only BVE objects, but I believe the bitmaps for the train panels should obey the same rules. If, as you say, the resolution is correct, i.e. 1024 x 1024 (It looks like a BVE4 panel,) then ensure that the bitmap is saved in a colour depth of 256, that is 8-bit, and this should solve your problem.
Enjoy!
Alan. ;)
 

velaro

Member
Joined
25 Jun 2007
Messages
91
Location
Reutlingen, Germany
Basically correct. 8 bit is not as important, but it can help older computers. If you do save the image with that color depth, sometimes the blue part is not saved as clear blue, 0,0,255, but something like 2,4,252, so you might have to edit the palette. What's really important is that each side of any image used in the panel has a length that is a power of two; most graphics cards will throw a fit if that rule is not followed.
 

Wim G.P.R

Member
Joined
7 Aug 2006
Messages
65
Location
CARDIFF
Sorry to say that me and Martin have been working on this version of the Kenji cab.

I promised months ago to animate the handles and Martin promised to get the sounds but we have both been doing other projects!

Otherthan that it is a fully working beta/wip..

Regards

Steve T.

 
Status
Not open for further replies.

Top