• Our new ticketing site is now live! Using either this or the original site (both powered by TrainSplit) helps support the running of the forum with every ticket purchase! Find out more and ask any questions/give us feedback in this thread!

need some Help

Status
Not open for further replies.
Sponsor Post - registered members do not see these adverts; click here to register, or click here to log in
R

RailUK Forums

T

Tom

Guest
MSTS is compatible and will work. MSTS was released before XP was released IIRC.
 

Coxster

Established Member
Joined
9 Jun 2005
Messages
9,244
I can assure you it works with XP mate. As said above, it was released before XP (2001) which is why they only list OS's upto Windows 2000.
 

Ben

Member
Joined
8 Jun 2005
Messages
999
Right Thanks lads

That means im getting it for Christmas :D
 

Chris

Member
Joined
1 Oct 2005
Messages
219
Location
Sunny Scotland
Don't buy it from PC world, its only £11.96 from Amazon.

There is even a new Xplosiv version starting at around 5.99 from some places. It was released on 25/11/05.
 

Chris

Member
Joined
1 Oct 2005
Messages
219
Location
Sunny Scotland
My be look around for th Xplosiv version. A lot of Xplosiv budget games are sold in the supermarkets, and maybe even in GAME, or they could see if there is a GAME near you. Maybe PC world might even be able to order it for you. Worth a try, then have a few extra quid to play with. It looks like this (the red one)
http://shopping.kelkoo.co.uk/b/a/ssc_100164013_microsoft_train_simulator.html

Hope you have some luck
 

Gareth Hale

Member
Joined
11 Jun 2005
Messages
941
MSTS runs on XP, when I drive a 158 it sometimes crashes. Other than that, MSTS is fine on XP 8)
 

Coxster

Established Member
Joined
9 Jun 2005
Messages
9,244
Gareth Hale said:
MSTS runs on XP, when I drive a 158 it sometimes crashes. Other than that, MSTS is fine on XP 8)
That's just classic MSTS, not the OS ;)
 

Tom B

Established Member
Joined
27 Jul 2005
Messages
4,602
Don't buy anything from RipOff World. You're more likely to be defrauded at a dodgy shop than online, if you're careful.

Since it's compatible with W2K it will be with XP since XP *is* W2K.
 
Status
Not open for further replies.

Top