• Dear Guest, and welcome to RailUK Forums. Our non-railway discussion forums are currently restricted until members have five or more posts, and you will not be able to make a new thread or reply to an existing one in this section until you have made five or more posts elsewhere on the forum.

RailUKforums and Internet Explorer 11

Status
Not open for further replies.

BingBong50

Member
Joined
17 Jan 2014
Messages
117
Location
Coulsdon
I have always used this forum via IE 11 but recently it has become very slow and sometimes freezes when moving to a different page. I then acccesed it using Google Chrome and everything was fast.

I have no problem using other websites with IE11.

Has anyone else had this problem?
 
Sponsor Post - registered members do not see these adverts; click here to register, or click here to log in
R

RailUK Forums

ainsworth74

Forum Staff
Staff Member
Global Moderator
Joined
16 Nov 2009
Messages
23,240
Location
Redcar
And even then IE11 is still installed by default on Windows 10 it just isn't immediately obvious how to access it.
 
Joined
7 Nov 2013
Messages
811
Location
Where my keyboard has no £ key
I have always used this forum via IE 11 but recently it has become very slow and sometimes freezes when moving to a different page. I then acccesed it using Google Chrome and everything was fast.
I have no problem using other websites with IE11.

Has anyone else had this problem?
I had this exact problem with the forum website several weeks ago.

I normally use IE 11 / Win 8.1, but the same slowness & freezing also happened on an iOS device (iPad).

No other websites were affected and my ISP connection speed was fine, so I concluded it was some problem with the website.

About two weeks ago I was on the point of posting exactly this question when the problem disappeared as suddenly as it had arisen - like "flicking a switch", although I hadn't altered any of my settings.

Duration of problem before it fixed itself:- about a week.
 
Last edited:

D365

Established Member
Joined
29 Jun 2012
Messages
8,323
Here's a more lasting solution: Carry on using a different browser ;)
 

BingBong50

Member
Joined
17 Jan 2014
Messages
117
Location
Coulsdon
I had this exact problem with the forum website several weeks ago.

I normally use IE 11 / Win 8.1, but the same slowness & freezing also happened on an iOS device (iPad).

No other websites were affected and my ISP connection speed was fine, so I concluded it was some problem with the website.

About two weeks ago I was on the point of posting exactly this question when the problem disappeared as suddenly as it had arisen - like "flicking a switch", although I hadn't altered any of my settings.

Duration of problem before it fixed itself:- about a week.
Glad I am not alone. I will continue using Google Chrome until it resolves.
 

russdx

Member
Joined
11 Jul 2016
Messages
7
Location
Bristol
Windows has always sucked when it comes to its web browser. I think ie11 is actually the first version to actually support most of the modern features all other browsers have supported for years. And it still sucks lol. Chrome has been the best in my opinion for years. We develop all our games at working using it.
 
Status
Not open for further replies.

Top