[SimSig] Hosting SimSig games.

Status
Not open for further replies.

yorkie

Forum Staff
Staff Member
Administrator
Joined
6 Jun 2005
Messages
48,234
Location
Yorkshire
The IP addresses beginning 192., 172., 10., etc (and other ranges) are all LOCAL IP addresses for your computer.

It is just the address for your computer on the network.

What you need to do is set up Port Forwarding (Don't ask me how - as it varies depending on your set-up. If using a Router, read the manual). Some companies may call "port forwarding" something else.

You need to forward the appropriate port(s) from your router to be directed to your PC.

So, if you just want people to be able to connect to your game, and your IP address was 192.168.1.1 then you forward port 1234 to 192.168.1.1 Then give out the EXTERNAL IP address of your router.

People on the internet must connect to your router's IP address, and your router forwards all requests on the SimSig port to your PC.

Port 1234 is for people to connect to your PC (ie, clients connecting), other ports are required for chained games (you'll see what they are when you try to connect).

Don't host SimSig games here unless you have checked your connection works with one other person first.
 
Sponsor Post - registered members do not see these adverts; click here to register, or click here to log in
R

RailUK Forums

Joined
25 Aug 2005
Messages
274
Location
Where 58's still operate in commercial service...
Personally I would use port 4321 Yorkie ;)

Port forwarding for SWEEX routers:

Go to your sweex router via the internet.
Log in to your own router. (read router manual for instructions)
Go to General setup
Go to NAT
select Enable NAT module function
Go to Port forwarding.
Fill in your LAN IP adress (you can find this by opening MSDOS and use the command ipconfig and open port 4321.
Now go to VCirtual server and select the enable option.
Add your private IP in the box, followed by 4321 2 times (private/public port)
Click Add.

Now reboot your PC.

Done. you should now be able to host.
 
Status
Not open for further replies.

Top