What are the rules on the rain command??

Status
Not open for further replies.

The Snap

Established Member
Joined
10 Jun 2005
Messages
3,118
Hi guys,
What are the rules on the rain command?? I have put the.beacon code in to my routes for BVE4, but no rain is falling. I don't know what is wrong. I am using this code: .Beacon 21;0;0;100,... Help! :( :x
Thanks, :)
 
Sponsor Post - registered members do not see these adverts; click here to register, or click here to log in
R

RailUK Forums

Tom B

Established Member
Joined
27 Jul 2005
Messages
4,555
Syntax looks fine, make sure the train you are using uses OS_ATS and has rain included. If in doubt test it on a known route.
 

Dennis

Established Member
Joined
8 Aug 2005
Messages
2,676
Location
Trowbridge
I've had a bit of trouble with the intensity of rain when trying to make it gradually start or stop - just try a different value for the intensity and see what happens.

The syntax you have there is the same as I have been using on my routes with the 158, 170 and Cl 37.

The only other thing I can think of is that when I do not include the beacon definitions...

.Beacon(0) brsigs\aws_null_0.x
.Beacon(1) brsigs\awsmagnet_1.x
.Beacon(2) brsigs\aws_tsr_2.x


...in the 'with structure' part, then where some of the rain beacons are, I see a little yellow rectangle in the trackbed and do not always get rain. I cannot explain this (not being very familiar with the beacon commands), but it might help.
 

ChrisCooper

Established Member
Joined
7 Sep 2005
Messages
1,787
Location
Loughborough
100 (as in .Beacon 21;0;0;100) won't work, the number has to be between 0 and 99. I'm not sure but I think it only reads the last 2 digits, so 100 reads as 00, so no rain.
 
Status
Not open for further replies.

Top